Vyatta NOS documentation

Learn how to install, configure, and operate Vyatta Network Operating System (Vyatta NOS), which helps to drive our virtual networking and physical platforms portfolio.

Configuring an LNS-to-LNS tunnel with RIP routes

This section shows the topology of a sample L2TPv3 LNS-to-LNS IPv4 tunnel with Routing Information Protocol (RIP) routes. To configure this sample LNS-to-LNS tunnel, perform the following steps in configuration mode.

  1. Configure the L2TPv3 tunnel settings and the LNS settings on the R1 router.
    1. Configure the L2TPv3 tunnel settings (Configuring the L2TPv3 tunnel settings on R1).
    2. Configure the RIP settings (Configuring the BGP settings of the LNS-to-LNS tunnel on R1).
  2. Configure the L2TPv3 tunnel settings and LNS settings on the R2 router.
    1. Configure the L2TPv3 tunnel settings (Configuring the L2TPv3 tunnel interface settings on R2).
    2. Configure the RIP settings (Configuring the RIP settings of the LNS-to-LNS tunnel on R2).
      Figure 1. Sample LNS-to-LNS IPv4 tunnel with RIP routes

      Configuring the L2TPv3 tunnel settings on R1 shows how to configure the L2TPv3 tunnel interface on R1.

      Table 1. Configuring the L2TPv3 tunnel settings on R1
      Step Command

      Specify IP as the encapsulation method to use for the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session encapsulation 'ip'
      

      Specify the local IP address of the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session local-ip '100.3.1.1'
      

      Specify the local session identifier of the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session local-session-id '40000000000'
      

      Specify the remote IP address of the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session remote-ip '200.3.1.1'
      

      Specify the remote session identifier of the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session remote-session-id '4000000000'
      

      Specify the IP address of the tunnel interface to which the R1 router is connected.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 address '2.2.2.1/29'
      

      Specify IP as the encapsulation method to use for the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session encapsulation 'ip'
      

      Specify the local IP address of the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session local-ip '100.3.1.1'
      

      Specify the local session identifier of the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session local-session-id '40000000000'
      

      Specify the remote IP address of the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session remote-ip '200.3.1.1'
      

      Specify the remote session identifier of the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session remote-session-id '4000000000'
      

      Specify the IP address of R1 (the local router).

      vyatta@vyatta# set interfaces l2tpeth lttp2222 address '2.2.2.2/29'
      

      Commit the configuration.

      vyatta@vyatta# commit
      

      Save the configuration.

      vyatta@vyatta# save
      

      Configuring the BGP settings of the LNS-to-LNS tunnel on R1 shows how to configure the RIP settings for the tunnel on R1. For more information about configuring these settings, refer to RIP Installing and Upgrading.

      Table 2. Configuring the BGP settings of the LNS-to-LNS tunnel on R1
      Step Command

      Specify a network for RIP.

      vyatta@vyatta# set protocols rip network '2.2.2.0/29'
      

      Specify a network for RIP.

      vyatta@vyatta# set protocols rip network '44.44.44.0/24'
      

      Commit the configuration.

      vyatta@vyatta# commit
      

      Save the configuration.

      vyatta@vyatta# save
      

      Exit the configuration mode.

      vyatta@vyatta# exit
      

      Show the configuration information for the lttp2222 interface.

      vyatta@vyatta# show interfaces l2tpeth lttp2222
      
      address 2.2.2.1/29
      l2tp-session {
              encapsulation ip
              local-ip 100.3.1.1
              local-session-id 2000000
              remote-ip 200.3.1.1
              remote-session-id 2000000
      }

      Show the configured RIP protocols.

      vyatta@vyatta# show protocols rip
      
       rip {
              network 2.2.2.0/29
              network 44.44.44.0/24
       }

      Configuring the L2TPv3 tunnel interface settings on R2 shows how to configure the L2TPv3 tunnel interface on R2.

      Table 3. Configuring the L2TPv3 tunnel interface settings on R2
      Step Command

      Specify IP as the encapsulation method to use for the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session encapsulation 'ip'
      

      Specify the local IP address of the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session local-ip '200.3.1.1'
      

      Specify the local session identifier of the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session local-session-id '40000000000'
      

      Specify the remote IP address of the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session remote-ip '100.3.1.1'
      

      Specify the remote session identifier of the lttp1111 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 l2tp-session remote-session-id '4000000000'
      

      Specify the IP address of the tunnel interface to which the router is connected.

      vyatta@vyatta# set interfaces l2tpeth lttp1111 address '1.1.1.2/24'
      

      Specify IP as the encapsulation method to use for the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session encapsulation 'ip'
      

      Specify the local IP address of the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session local-ip '200.3.1.1'
      

      Specify the local session identifier of the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session local-session-id '40000000000'
      

      Specify the remote IP address of the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session remote-ip '100.3.1.1'
      

      Specify the IP address of the tunnel interface to which the router is connected.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 address '2.2.2.2/29'
      

      Specify the remote session identifier of the lttp2222 L2TPv3 tunnel interface.

      vyatta@vyatta# set interfaces l2tpeth lttp2222 l2tp-session remote-session-id '4000000000'
      

      Commit the configuration.

      vyatta@vyatta# commit
      

      Save the configuration.

      vyatta@vyatta# save
      

      Configuring the RIP settings of the LNS-to-LNS tunnel on R2 shows how to configure the RIP settings for the tunnel on R2. For more information about configuring these settings, refer to RIP Installing and Upgrading.

      Table 4. Configuring the RIP settings of the LNS-to-LNS tunnel on R2
      Step Command

      Specify a network for RIP.

      vyatta@vyatta# set protocols rip network '2.2.2.0/29'
      

      Specify a network for RIP.

      Commit the configuration.

      vyatta@vyatta# commit
      

      Save the configuration.

      save