home

Supported platforms

Vyatta documentation

Learn how to install, configure, and operate the Vyatta Network Operating System (Vyatta NOS) and Orchestrator, which help drive our virtual networking and physical platforms portfolio.

Route reflectors

Router reflectors are another technology designed to help BGP scale to a large AS. In a route reflector configuration there is at least one route reflector server and one or more route reflector clients. In example shown in the following figure, router R1 is the route reflector server and router R2, R3, and R4 are the route reflector clients.

Note: We assume that the routers in AS200 and AS300 are configured appropriately as eBGP peers.
Figure 1. BGP route reflector

This example assumes that the configurations in previous sections have been performed, and that interfaces and OSPF have been configured. If you are starting from a clean base system, you need not delete previous configuration.

Table 1. Creating route reflectors

Router

Step

Commands

R1

Delete current BGP configuration.

vyatta@R1# delete protocols bgp

R1

To allow routes from AS200 to be injected into RIB on R2.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.22 nexthop-self

R1

Set R2 in the same AS as R1.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.22 remote-as 100

R1

Set R2 as a route reflector client.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.22 address-family ipv4-unicast route-reflector-client

R1

Define the IP address on the local R1 router that is used to peer with the R2 router.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.22 update-source 10.0.0.11

R1

To allow routes from AS200 to be injected into RIB on R3.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.33 nexthop-self

R1

Set R3 in the same AS as R1.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.33 remote-as 100

R1

Set R3 as a route reflector client.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.33 address-family ipv4-unicast route-reflector-client

R1

Define the IP address on the local R1 router that is used to peer with the R3 router.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.33 update-source 10.0.0.11

R1

To allow routes from AS200 to be injected into RIB on R4.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.44 nexthop-self

R1

Set R4 in the same AS as R1.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.44 remote-as 100

R1

Activate the neighbor for the IPv4 unicast address family to enable the exchange IPv4 unicast routes.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.44 address-family ipv4-unicast

R1

Set R4 as a route reflector client.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.44 address-family ipv4-unicast route-reflector-client

R1

Define the IP address on the local R1 router that is used to peer with the R4 router.

vyatta@R1# set protocols bgp 100 neighbor 10.0.0.44 update-source 10.0.0.11

R1

Set the AS200 router in a different AS than R1.

vyatta@R1# set protocols bgp 100 neighbor 88.88.88.2 remote-as 200

R1

Set the outbound filter.

vyatta@R1# set protocols bgp 100 neighbor 88.88.88.2 route-map export eBGP-EXPORT

R1

Set the inbound filter.

vyatta@R1# set protocols bgp 100 neighbor 88.88.88.2 route-map import eBGP-IMPORT

R1

Set the network to advertise.

vyatta@R1# set protocols bgp 100 address-family ipv4-unicast network 172.16.0.0/24

R1

Set the router ID.

vyatta@R1# set protocols bgp 100 parameters router-id 10.0.0.11

R1

Commit the configuration.

vyatta@R1# commit

R1

Display the BGP configuration.

vyatta@R1# show protocols bgp 
 100 {
     neighbor 10.0.0.22 {
         nexthop-self
         remote-as 100
         route-reflector-client
         update-source 10.0.0.11
     }
     neighbor 10.0.0.33 {
         nexthop-self
         remote-as 100
         route-reflector-client
         update-source 10.0.0.11
     }
     neighbor 10.0.0.44 {
         nexthop-self
         remote-as 100
         route-reflector-client
         update-source 10.0.0.11
     }
     neighbor 10.0.0.44 {
          address-family ipv4-unicast
     }
     neighbor 88.88.88.2 {
         remote-as 200
         route-map {
             export eBGP-EXPORT
             import eBGP-IMPORT
         }
     }
     address-family ipv4-unicast {
          network 172.16.0.0/24 
         }
     }
     parameters {
         router-id 10.0.0.11
     }
 }
vyatta@R1#

R2

Delete current BGP configuration.

vyatta@R2# delete protocols bgp

R2

Set R1 in the same AS as R2.

vyatta@R2# set protocols bgp 100 neighbor 10.0.0.11 remote-as 100

R2

Define the IP address on the local R2 router that is used to peer with the R1 router.

vyatta@R2# set protocols bgp 100 neighbor 10.0.0.11 update-source 10.0.0.22

R2

Activate the neighbor for the IPv4 unicast address family to enable the exchange IPv4 unicast routes.

vyatta@R2# set protocols bgp 100 neighbor 10.0.0.44 address-family ipv4-unicast

R2

Set the network to advertise.

vyatta@R2# set protocols bgp 100 address-family ipv4-unicast network 172.16.0.0/24

R2

Set the router ID.

vyatta@R2# set protocols bgp 100 parameters router-id 10.0.0.22

R2

Commit the configuration.

vyatta@R2# commit

R2

Display the BGP configuration.

vyatta@R2# show protocols bgp 
 100 {
     neighbor 10.0.0.11 {
         remote-as 100
         update-source 10.0.0.22
     }
     neighbor 10.0.0.44 {
          address-family ipv4-unicast
     }
     address-family ipv4-unicast {
          network 172.16.0.0/24 
          }
     }
     parameters {
         router-id 10.0.0.22
     }
 }
vyatta@R2#

R3

Delete current BGP configuration.

vyatta@R3# delete protocols bgp

R3

Set R1 in the same AS as R3.

vyatta@R3# set protocols bgp 100 neighbor 10.0.0.11 remote-as 100

R3

Define the IP address on the local R3 router that is used to peer with the R1 router.

vyatta@R3# set protocols bgp 100 neighbor 10.0.0.11 update-source 10.0.0.33

R3

Activate the neighbor for the IPv4 unicast address family to enable the exchange IPv4 unicast routes.

vyatta@R3# set protocols bgp 100 neighbor 10.0.0.44 address-family ipv4-unicast

R3

Set the network to advertise.

vyatta@R3# set protocols bgp 100 address-family ipv4-unicast network 172.16.0.0/24

R3

Set the router ID.

vyatta@R3# set protocols bgp 100 parameters router-id 10.0.0.33

R3

Commit the configuration.

vyatta@R3# commit

R3

Display the BGP configuration.

vyatta@R3# show protocols bgp 
 100 {
     neighbor 10.0.0.11 {
         remote-as 100
         update-source 10.0.0.33
     }
     neighbor 10.0.0.44 {
          address-family ipv4-unicast
     }
     address-family ipv4-unicast {
         network 172.16.0.0/24 
         }
     }
     parameters {
         router-id 10.0.0.33
     }
 }
vyatta@R3#

R4

Delete current BGP configuration.

vyatta@R4# delete protocols bgp 

R4

To allow routes from AS300 to be injected into RIB on R1.

vyatta@R4# set protocols bgp 100 neighbor 10.0.0.11 nexthop-self

R4

Set R1 in the same AS as R4.

vyatta@R4# set protocols bgp 100 neighbor 10.0.0.11 remote-as 100

R4

Define the IP address on the local R4 router that is used to peer with the R1 router.

vyatta@R4# set protocols bgp 100 neighbor 10.0.0.11 update-source 10.0.0.44

R4

Set the AS300 router in a different AS than R4.

vyatta@R4# set protocols bgp 100 neighbor 99.99.99.2 remote-as 300

R4

Set the outbound filter.

vyatta@R4# set protocols bgp 100 neighbor 99.99.99.2 route-map export eBGP-EXPORT

R4

Set the inbound filter.

vyatta@R4# set protocols bgp 100 neighbor 99.99.99.2 route-map import eBGP-IMPORT

R4

Activate the neighbor for the IPv4 unicast address family to enable the exchange IPv4 unicast routes.

vyatta@R4# set protocols bgp 100 neighbor 10.0.0.44 address-family ipv4-unicast

R4

Set the network to advertise.

vyatta@R4# set protocols bgp 100 address-family ipv4-unicast network 172.16.0.0/24

R4

Set the router ID.

vyatta@R4# set protocols bgp 100 parameters router-id 10.0.0.44

R4

Commit the configuration.

vyatta@R4# commit

R4

Display the BGP configuration.

vyatta@R4# show protocols bgp 
 100 {
     neighbor 10.0.0.11 {
         nexthop-self
         remote-as 100
         update-source 10.0.0.44
     }
     neighbor 99.99.99.2 {
         remote-as 300
         route-map {
             export eBGP-EXPORT
             import eBGP-IMPORT
         }
     }
     address-family ipv4-unicast {
          network 172.16.0.0/24 
         }
     }
     parameters {
         router-id 10.0.0.44
     }
 }
vyatta@R4#